Intermittent API/portal timeout
Incident Report for Simwood
Resolved
Reports are processed sequentially and a single customer was effectively causing a Denial of Service with thousands of requests for a heavy report, which was in turn delaying others beyond the timeout the API has. The API, portal and the platform in general were otherwise fine and this functioned as expected.
Posted Nov 29, 2021 - 16:39 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 29, 2021 - 13:23 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 29, 2021 - 13:04 UTC
Investigating
We are currently investigating this issue.
Posted Nov 29, 2021 - 12:54 UTC
This incident affected: API and Portal.