Bristol Office
Incident Report for Simwood
Resolved
This incident has been resolved.
Posted about 2 months ago. May 28, 2019 - 15:08 UTC
Identified
Due to a local issue within the Bristol office we are currently unable to receive incoming calls to our main telephone number and ticket responses may be delayed.

All Simwood services, and the Simwood network, remain unaffected.

Please accept our apologies for any inconvenience this may cause.
Posted about 2 months ago. May 28, 2019 - 11:56 UTC
This incident affected: Operations Desk.