Intermittent issues to UK 080 destinations.
Incident Report for Simwood
Resolved
This has been resolved by rerouting affected destinations.
Posted 19 days ago. Aug 27, 2019 - 16:35 UTC
Identified
We're aware of intermittent issues reaching some UK 080 (Freephone) destinations.

We're working to reroute traffic and this should be complete shortly.

Inbound calls to Simwood or hosted 080 numbers are not affected.
Posted 19 days ago. Aug 27, 2019 - 16:22 UTC
This incident affected: Voice.