O2 Mobile Network Issues
Incident Report for Simwood
Resolved
O2 have announced that service is returning to normal and will be fully restored by around 0300.
Posted 10 days ago. Dec 07, 2018 - 00:28 UTC
Identified
We are aware of an outage affecting the O2 4G LTE network nationally. For more information see https://status.o2.co.uk/

As a result, calls to some O2 numbers (and numbers ported to O2) may fail if the destination handset is on the 4G/LTE network. O2 is advising customers to disable 4G (using the 3G or 2G network which is working in most areas)

Whilst this fault is entirely outwith our control, we anticipate you will see a high number of call failures to O2 destinations as a result.
Posted 11 days ago. Dec 06, 2018 - 09:44 UTC
This incident affected: Voice.