Calling the Simwood Office
Incident Report for Simwood
Resolved
This incident has been resolved.
Posted 17 days ago. Apr 02, 2019 - 08:16 UTC
Identified
We are aware of an issue with calls to our office PBX. We are working to fix the issue, but in the meantime you can contact us by sending an email to team@simwood.com. Just a reminder the Simwood test line is 0330 122 9999 and this is available 24x7.
Posted 17 days ago. Apr 02, 2019 - 07:52 UTC