Office Telephones
Incident Report for Simwood
Resolved
This incident has been resolved.
Posted Feb 04, 2016 - 17:35 UTC
Identified
We are currently experiencing a technical issue affecting connectivity, provided by a third party, at our Southampton office.

This does not affect our services in any way, however you may be unable to contact the team by telephone.

Please eMail team@simwood.com or raise a ticket at https://support.simwood.com/ if you require assistance.

We apologise for any inconvenience this may cause.
Posted Feb 04, 2016 - 16:33 UTC