Simwood Mobile terminated traffic failing
Incident Report for Simwood
Resolved
This issue is now resolved - we have narrowed it down to a configuration issue with our RAN partner.

This issue will be investigated by both parties and we will require a full explanation as to why changes were made without us being notified; although this is a non-production beta product this kind of outage is wholly unacceptable.
Posted Jul 01, 2015 - 15:59 UTC
Investigating
We are currently investigating an issue affecting calls made to Simwood developer SIMs.
Posted Jul 01, 2015 - 15:06 UTC