Portal Issues
Incident Report for Simwood
Resolved
Normal service has, once again, been restored to the Portal.

We will continue to monitor the service.
Posted Jul 27, 2015 - 17:26 UTC
Investigating
We are experiencing further issues with the portal, please bear with us while we investigate.
Posted Jul 27, 2015 - 15:23 UTC