Delays in Operations Desk e-mail responses
Incident Report for Simwood
Resolved
Zendesk have reported that the issue causing these delays has been resolved.
Posted Dec 17, 2015 - 16:20 UTC
Investigating
Due to an ongoing issue with Zendesk, our third party helpdesk supplier, there may be delays in replying to e-mail tickets sent to team@simwood.com and other support e-mail addresses.

For urgent issues please call our Operations Team on 0330 122 3000
Posted Dec 17, 2015 - 13:15 UTC