03 Numbering from Mobiles
Incident Report for Simwood
Resolved
We understand that this issue is now resolved.

As we were not directly affected, we do not have access to any further information regarding this fault.
Posted Sep 29, 2016 - 11:47 UTC
Monitoring
We have been made aware of a nationwide issue affecting some mobile operators, specifically Vodafone and O2, that has affected their customers' ability to call UK 03 Non-Geographic Numbers (from any provider)

We are still seeing traffic to our 0330 122 range and others from these networks, suggesting that this is an intermittent issue, and our own test calls have completed as expected.

The problem is outwith the Simwood network, however we will continue to keep you informed with any further information we receive.
Posted Sep 29, 2016 - 10:30 UTC