Portal Speed Issues
Incident Report for Simwood
Resolved
Normal service has resumed on the portal, apologies for any inconvenience.
Posted Jul 27, 2015 - 15:13 UTC
Investigating
Our portal at https://portal.simwood.com is currently experiencing some speed issues.

Our engineers are investigating.
Posted Jul 27, 2015 - 15:00 UTC